Windows XP Survival Skills

Geog 316 – Fall 2008

Using a GIS requires a basic understanding of the operating system of the computer platform used by the GIS.  The operating system is the software that controls the computer's hardware devices (e.g. disk drive, monitor, speakers), provides a convenient user interface to those devices (e.g. the file system is a logical view of data on a hard drive that is really just a strings of 1's and 0's), and runs application programs.  Windows and Unix are examples of operating systems.  This introductory exercise is intended to make sure that everyone has the basic skills with the Windows XP operating system that they will need for Geography 316 and the GIS classes beyond.  Note that these instructions are specifically designed for the hardware and software configuration in the GIS lab, and operations may differ slightly on other computers.  

1. The Desktop

When you log on to the campus network, the set of icons, taskbars, and buttons that appear on the screen is the desktop.  It is part of the user interface that allows you to interact with the computer.  The desktop may look slightly different on each machine you use because different programs have been installed and different "shortcut" icons created ("shortcut" icons immediately start a program without going through the usual menu system).  The most important parts of the desktop for us will be: 1) the "my computer" icon; 2) the Start button; and 3) the task bar.  By the end of the exercise, you should understand the use of each of these.

2. "My Computer"
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The "my computer" icon, located in the upper left portion of the screen, gives you access to various hardware components of your computer, e.g. the floppy drive, the hard drive, and printers.  You will use it most frequently to look at, copy, and move files on your disk.

A) Open the "my computer" icon by moving the mouse pointer on top of it and then double-

clicking the left mouse button.  

["Double-clicking" means to press the mouse button rapidly twice.  Most Windows controls are done with the left mouse button, so the button specification will be omitted in the rest of this exercise.  Unless you are instructed to do otherwise, assume that you are to use the left button.]

[Note: In general, single-clicking on a windows object, such as an icon, selects that object.  It will appear highlighted on the screen, but no action is taken.  Double-clicking on an object opens it.  If you are trying to open an icon or file but nothing is happening, make sure you are double-clicking rather than single-clicking.]

A window appears showing the hardware devices attached to your computer.  Note that it contains icons for the various devices and network devices available on this machine. 

· The hard drive has been partitioned into two sections, (Local Disk) C: and (Permanent) F or T:.  VERY IMPORTANT:  The C: drive is wiped clean to its original state every time the computer is rebooted!!  You cannot store any information on it.  You should store files on the T: drive during class, and then transfer them to a  memory stick or a CD at the end of class.

· The zip drive is D:

Set View Options

B) Look at the contents of the hard drive by double-clicking on the C: drive icon.  

C) Making File Extensions Visible.  Single-click with the left mouse button on the word "Tools" to open the Tools menu.  Click on the last menu item, "Folder Options".  A window will appear.    Click on the “View” tab to switch to that set of options.  Make sure that the box labeled “Hide file extensions for known file types” is not checked, if so, click in the box to uncheck it.  Click the OK button, then scroll down in the C: window to see that file extensions like .bat, .dbf are now visible at the end of file names.  It is a good idea to operate with file extensions visible.

D) On the View Menu, experiment with the following display modes --  Thumbnails, Tiles Icons, List and Details.  What is the difference between Thumbnails and Icons?  What about the difference between List and Details?  For our purposes, we want Details!  On the View Menu, click on Arrange Icons By and then on Name. This means that folders then files will be listed in alphabetical order.

3. The Directory Hierarchy

In the view. you see some files and some folders or directories.  The terms "folder" and "directory" are interchangeable.  Folders are a way of organizing files.  By putting a group of related files together in one folder (say, all the files for a GIS of Warren County) you can more easily keep track of them and find them when needed; they won't get mixed up with files for another project (say, a GIS of Barren County).  Folders are easy to identify -- the yellow folder icon always marks them:
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Folders contain files, but they can also contain other folders.  Files and folders are arranged in a hierarchical system.  Here is a partial listing of the hard drive contents:
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Some basic terminology:

Root or root directory – the topmost location in the directory hierarchy on any disk; symbolized by a backslash character, \

Siblings – files or folders at the same level of the directory hierarchy; ESRI and Windows are siblings

Child – a file or folder contained by a folder; Europe is a child of Esridata

Parent – a folder that contains other folders or files; Usa is a parent of cities.prj

4. Make a Folder on your T: drive.

If you have not already done this,  create a new folder to hold your work for this class.  The folder name can be named using the first seven letters of your last name followed by your first initial, a total of eight characters.  If you have named your file something else you can rename it as follows:  right click on the directory.  A dropdown menu will appear.  Scroll down and click on “RENAME”.  The folder name will now be highlighted – you can just type over the existing name. As we progress in this course, you will want to make subfolders under this folder to organize your work on individual exercises (e.g., Lab1, Lab2, HmWk or whatever makes sense to you (and me of course!)).
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 to bring you back to viewing all the drives on your computer.  Make your currently open window look at the T: drive instead of the C: drive.  Hint:  Double click on the T: drive.
B) On the File menu, select New and then Folder.  This creates a folder with the default name "New Folder", but you are immediately given an opportunity to change the file name.  Note that "New Folder" is highlighted in blue and there is a box around it.  This signals that Windows is waiting for you to type the new folder name. Type your first seven letters of your last name followed by your first initial and press the enter key.  If you hit a wrong key or otherwise need to change the file name, go to the File menu, then select Rename with that folder highlighted.
5. Copy a dataset

We will now copy a set of files that we will use for the rest of this exercise.  

A) Double-click on your folder to open it.  It is empty at this point.

B) Double-click on the “Instructor-Connect” icon located on your desktop.  Note:  Only ten computers can be connected at any given time.

C) In the new window, open “Cary”, then open “ExHmWK”, and then open “WinExDwnld”.  In the “WinExDwnld” folder, you should see the file “WinExercise.EXE”.  This is a self-extracting file that contains the data for this exercise.  Double click on the executable.  This will open a window that will request information from you for where to extract your data.  To the right of the “Extract to:” input box, click on “Browse” and navigate to your folder that you just created on the F: drive.  Press “Ok” when finished.  Next press “Extract” and your data will uncompress and be copied to the path displayed in the “Extract to:”  input box.

D) Close the “Instructor Connect” window.  Your computer will disconnect within two minutes after closure.  This will allow others to connect.

E) In your directory, open the “Intro to Window” folder and then the ”Scavenger Hunt” folder.  (Note: If you double-click on the folder name rather than the little yellow folder icon, Windows thinks you want to rename the folder and highlights the name in blue for you.  Just double click to the folder icon to proceed.)
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Note that "Scavenger Hunt" has moved into the Address box at the top of the window and its icon now looks like an open folder.  The folder appearing in this box is the current working directory, the directory you are currently "in".  If you do not see the Scavenger Hunt folder in the box as shown, then you need to turn on the toolbar for the window: On the View Menu, select Toolbar then Address Bar.  The contents of the folder are shown in the window below the address.

The folder "Scavenger Hunt" contains _____ folder(s) and _____ files.

G) Double-click on the folder "raster" to open it.

The folder "raster" contains _____ files.

The current working directory is _____________________.

H) Find the button that looks like a folder with an arrow on it.  This is the "Up One Level" button:
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Click this button to go to the parent directory of the current working directory.  The parent directory of a file or folder is simply the directory that contains that file or folder.

The parent directory of "raster" is _____________________.

The parent directory of "vector.doc" is ____________________.

The parent directory of "Scavenger Hunt" is _____________________.

Right now your current working directory should be "Scavenger Hunt".  If you have navigated elsewhere, get back to this directory.

6. Files and File Names

From the computer user's viewpoint, the basic data unit is the file.  A file may contain a report written in word processing software, a spreadsheet for a program such as Excel, a GIS layer, or a multitude of other types of data.  Each computer program you use will likely have its own way of organizing data in files.  This method of organization is called the file format, and we will see examples of them later.  Some programs can read or import the file formats of other programs quite easily (e.g. Microsoft Word can read WordPerfect files and vice versa).  Because of the complexity of GIS data, it is not nearly so easy to transfer data between different GIS programs.  


File names have two parts -- the base name and the file extension.  

                                                                       vector.doc

In this example, the base name is "vector" and the file extension is "txt".  Files do not have to have an extension, but if they do, the extension is separated from the base name by a period, which in computer circles is pronounced "dot" when spoken aloud.  This file name, then, is "vector-dot-txt".


The file extension is 1 to 3 characters in length and usually tells you what kind of file it is.  That is, the extension indicates the file format.  Some extensions commonly used are:

.doc - Word document

.shp - ArcView shape file

.adf – Arc Data File

.dbf - Dbase database file (the database file format used by a number of programs, including pc Arc/Info and ArcView)

.txt - plain text file (contains no special word processor formatting)

.xls - Excel database file

.rtf - rich text format (a file format designed to allow formatted text files to be moved between operating systems, e.g. Windows, Macintosh, OS/2

Filename rules

· Base names of 13 or fewer characters

· File extensions of 3 letters

· No spaces in filenames nor symbols and they cannot begin with a number!

Actually, Windows XP has eliminated the 3 character limit to the file extension.  You can now create files with longer extensions, if you wish.  However, the standard extensions used by programs and especially GIS programs will remain 3 characters to ensure backwards computability with older programs and operating systems.

Windows has also removed restrictions on the length of the base file name and use of spaces, so you can create files with names as long as you wish.  However, some of the GIS programs we will use do not recognize long file names.  Therefore, you should use base names with 13 or fewer characters.

Viewing Filenames

"My Computer" can display files ordered by base name or by file extension (file type).  Directories are shown first, followed by regular files. Let's arrange them by file extension: on the View Menu, select Arrange Icons By, then Type.  Now the files are listed alphabetically by extension.  This is useful when you have a directory containing many types of data.  On the View set the display type to List.

Many times people are puzzled because they sometimes don't see the file extensions.  Windows can be set to either show or hide the file extensions.  Each computer you log on to may be set differently in this regard, so you need to recognize when the file extensions are hidden and be able to un-hide them.  Let's turn off the file extensions.  Click on Tools in the main menu, select Folder Options, then click on the View tab and click the box next to "Hide extensions for known file types" so that a check appears.  Click OK.

What secret message appears? ____________________________________

(Hint: (1) Explore the “Arrange Icons By” that’s in the context menu that appears when you right-click and click on TYPE (2) read the file names vertically as if they were a sentence.)

Now, turn the extensions back on. You should normally operate with file extensions on.  It is possible to create files with names such as

vector.doc.doc

(where the base name is vector.doc and the file extension is the second.doc) when file extensions are hidden.  If you tried to access the file "vector.doc" that you thought was there (because file extension were hidden), you would be told it did not exist!

7. File Details

"My Computer" can display file details, such as when you created your files and how big they are.  When you have multiple versions of a file, this information is useful for figuring out which is the most recent.  On the View Menu, select Details.  You can make your window wider if necessary by clicking-and-dragging the edge of the window (Move the mouse pointer to the edge of the window.  When it changes to a double-headed arrow, click and drag to the place you want the edge to be.)

How big is the file faster? __________

Which file is more up-to-date – corrector or is?  

8. Pathnames

Files within the current working directory can be accessed by their simple filename, as discussed above.  This is an example of relative naming -- it's relative to the current working directory.  Two files can have the same simple filename, say name.doc, but be located in different folders.  Which file is actually accessed when "name.doc" is specified depends on which folder is the current working directory.

Sometimes, you need to use absolute naming to unambiguously specify the complete pathname of a file.  The pathname starts at the root directory of the disk, the drive letter followed by a colon and backslash, “: \”, and lists every folder on the path down to and including the file or folder being named.  The root directory of the floppy drive is “A:\”.

What is the root directory of the hard drive where you are storing your files? _________

The pathname for vector is:

T:\<your_name>\Intro to Windows\Scavenger Hunt\vector

Another way to look at the pathname is that it names the parent directory of the file, the parent directory's parent, and all parents back to the root directory.

What is the parent directory of raster? _______________

What is the parent directory of Scavenger Hunt? ________________

Scavenger Hunt has a sibling, Survivor, which has a child, Island.
What is the complete pathname for Island? _______________________________

9. Copying Files between Directories

You are now going to copy corrector and vector to the folder raster.  After copying, the original versions will still exist in the folder Scavenger Hunt, but new files with the exact same contents will be located in the folder raster.

A) Navigate to the folder containing vector and corrector. 

B) The files can be copied singly, but it's almost as easy (and faster) to copy them both at once.  To do that, we just have to get them both selected.  Single click on corrector to select it -- the name will appear highlighted in blue. (If you double click on the filename, you will be trying to open the file.)  Now hold down the Ctrl key while you click on vector.  Both names should now be highlighted. [Note: the shift key will allow you to select any number of sequential filenames with one click.]

C) On the Edit menu, select Copy. (Or you could press the key sequence Ctrl-C, a short-cut for the copy operation. Or right-click on the highlighted files and select “copy” from the context menu that appears.)

D) Navigate to the destination directory, raster.

E) On the Edit menu, select Paste. (Or you could press Ctrl-V, a short-cut for the paste operation Or right-click in the empty space and select “paste” from the context menu that appears)

There are now two copies each of vector and corrector.  Although these two currently have the same contents, as soon as you edit one version, they will no longer be the same.  Changing one does NOT automatically update the other.

The Original "Survivor"

You will find a directory called "survivor" in your personal data directory.  It contains another folder,  "Island", which is inhabited by a variety of characters who share the goal of reaching the "Mainland".  Apply the skills covered in lab today to accomplish the following tasks:

· Create a folder named "Mainland" in your "survivor" directory.

You can think of an absolute pathname as a complete "map" to a folder.  Help the characters find the mainland by determining the absolute pathname to the Mainland folder:

_________________________________________________________

· Clone the Skipper (by making a copy of this file).  Hint: use the Edit-Copy, Edit-Paste method just practiced.

· Rescue your four favorite characters by moving them to the Mainland folder.  Use Shift-click and/or Ctrl-click to select and move them all at once.

· Take the treasure with you to the mainland.  It's in island\beach\lagoon\reef\.

· Change the name of "Mainland" to "TV_Waste_Land".

· Make a backup of your work by copying the folder survivor (and all its contents) to a disk and submit it to your instructor along with your answers (i.e., this document).

“My Computer” verses Windows Explorer
Compare the “My Computer” application to Windows Explorer.  How are they different?  What are the advantages and disadvantages?
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